User Tools

Site Tools


semplice:develop:3.0:relnotes:alpha1

Semplice 3.0alpha1 "pulse" Release Notes

Introduction and warnings

Semplice is a cool, free, light, simple, fast and libre GNU/Linux distribution, based on Debian Sid, the “unstable” branch of the Debian project. Because of its instability, Semplice Linux is not ideal in production systems, and there is no guarantee that everything works, now or in the near future.

This build was compiled in 2012-02-06.

Known issues

(Live) non-free removal produces output

If using nonfree=false boot parameter (only in live), the non-free removal script displays output during the boot phase. This issue will not affect the Semplice Live usage.

Summary of the CD content

Semplice Live

The Semplice Live System is a Semplice installation that works from a CD. With Semplice Live, you can try Semplice without doing changes to your computer. The changes that you do in the Live System will be deleted at the system shutdown.

The Semplice Live System cointains:

Openbox 3.5.0

Openbox is the Window Manager used in Semplice. This, with other applications, make the default desktop of Semplice Linux.

Linux Kernel 3.2.4

This release contains the Linux Kernel 3.2.4, bringing the latest and greatest drivers and performance.

Chromium web browser 16.0.912.77

Chromium is the not-branded version of the famous Google Chrome Web Browser. It is based on the rendering engine WebKit.

Exaile 0.3.2.2 and GNOME MPlayer 1.0.5

Exaile is a music manager and player for GTK+ written in Python. It incorporates automatic fetching of album art, lyrics fetching, Last.fm scrobbling, support for many portable media players, internet radio such as shoutcast, and tabbed playlists.

GNOME MPlayer: The power of MPlayer combined with a friendly interface for your desktop. You can play all your multimedia (audio, video, CD, DVDs, and VCDs, streams etc. with full DVD and MKV chapter support), organize, sort and create playlists, take screenshots while playing videos, be notified about media changes, retrieve cover art and more.

Abiword 2.9.2 and Gnumeric 1.10.17

AbiWord is a free word processing program similar to Microsoft® Word. It is suitable for a wide variety of word processing tasks. Gnumeric is a free spreadsheet similar to Microsoft® Excel.

Pidgin Internet Messenger 2.10.1

Pidgin is a graphical, modular Instant Messaging client capable of using AIM/ICQ, Yahoo!, MSN, IRC, Jabber/XMPP, Napster, Zephyr, Gadu-Gadu, Bonjour, Groupwise, Sametime, SILC, SIMPLE, QQ, Facebook and MySpaceIM all at once.

Guake Terminal 0.4.2

Guake is a GTK+ drop-down terminal. To invoke it, just press F12 - press F12 again to hide it.

Changes from 2.0.1

(The list below is provided only to have a summary list of changes. It is not relevant to the 64bit release).

changes_2.0.1_3.0a1.txt
> abiword	2.9.2+svn20120123-1
> abiword-common	2.9.2+svn20120123-1
> accountsservice	0.6.15-3
> adduser	3.113+nmu1
> alan	0.5.5-1
> alan-config-semplice	0.5.5-1
> alan-ext-linstaller	2.10.7-1
> alsa-utils	1.0.24.2-5
> binutils	2.22-5
> bluetooth	4.98-2
> bluez	4.98-2
> bluez-utils	4.98-2
> chromium	16.0.912.77~r118311-1
> chromium-browser	16.0.912.77~r118311-1
> chromium-inspector	16.0.912.77~r118311-1
> cpp-4.6	4.6.2-12
> cron	3.0pl1-121
> cups	1.5.0-16
> cups-client	1.5.0-16
> cups-common	1.5.0-16
> cups-driver-gutenprint	5.2.7-5
> cups-filters	1.0~b1-3
> cups-ppdc	1.5.0-16
> debianutils	4.2.1
> dmidecode	2.11-5
> fontconfig	2.8.0-3.1
> fontconfig-config	2.8.0-3.1
> fonts-droid	20101110+git-3
> foomatic-db-gutenprint	5.2.7-5
> gcc-4.6-base	4.6.2-12
> gstreamer0.10-plugins-ugly	0.10.18-3+b2
> gtk2-engines-pixbuf	2.24.9-2
> ijsgutenprint	5.2.7-5
> initscripts	2.88dsf-22
> insserv	1.14.0-2.2
> iso-codes	3.32.1-1
> less	444-2
> libabiword-2.9	2.9.2+svn20120123-1
> libaccountsservice0	0.6.15-3
> libaudclient2	3.2-1
> libaudio2	1.9.3-4
> libaudiofile1	0.3.3-2
> libaudit0	1:1.7.18-1.1
> libavcodec53	4:0.8-1+b1
> libavformat53	4:0.8-1+b1
> libavutil51	4:0.8-1+b1
> libbluetooth3	4.98-2
> libburn4	1.2.0-1
> libc-bin	2.13-26
> libc6	2.13-26
> libcairo-perl	1.090-1
> libcdaudio1	0.99.12p2-11
> libcups2	1.5.0-16
> libcupscgi1	1.5.0-16
> libcupsfilters1	1.0~b1-3
> libcupsimage2	1.5.0-16
> libcupsmime1	1.5.0-16
> libcupsppdc1	1.5.0-16
> libcurl3-gnutls	7.24.0-1
> libdirac-encoder0	1.0.2-5
> libesd0	0.2.41-10+b1
> libexif12	0.6.20-2
> libfm-data	0.1.17-1
> libfm-gtk1	0.1.17-1
> libfm1	0.1.17-1
> libfontconfig1	2.8.0-3.1
> libgail18	2.24.9-2
> libgcc1	1:4.6.2-12
> libgdk-pixbuf2.0-0	2.24.1-1
> libgdk-pixbuf2.0-common	2.24.1-1
> libgfortran3	4.6.2-12
> libglib2.0-0	2.30.2-6
> libglib2.0-bin	2.30.2-6
> libglib2.0-data	2.30.2-6
> libgmp10	2:5.0.3+dfsg-1
> libgnome-keyring-common	3.2.2-2
> libgnome-keyring0	3.2.2-2
> libgomp1	4.6.2-12
> libgpg-error0	1.10-3
> libgpod4	0.8.2-6
> libgtk2-perl	2:1.242-1
> libgtk2.0-0	2.24.9-2
> libgtk2.0-common	2.24.9-2
> libgutenprint2	5.2.7-5
> libicu48	4.8.1.1-3
> libisofs6	1.2.0-1
> libjim0debian2	0.73-2
> libjpeg8	8d-1
> libkeyutils1	1.5.5-1
> libmad0	0.15.1b-7
> libmhash2	0.9.9.9-1.1
> libmp3lame0	3.99.4+repack1-1
> libnewt0.52	0.52.14-8
> libnm-gtk-common	0.9.2.0-2
> libnm-gtk0	0.9.2.0-2
> libpam-modules	1.1.3-7
> libpam-modules-bin	1.1.3-7
> libpam-runtime	1.1.3-7
> libpam0g	1.1.3-7
> libpcsclite1	1.8.2-1
> libperl5.14	5.14.2-7
> libpostproc52	4:0.8-1+b1
> libprocps0	1:3.3.2-3
> libproxy0	0.3.1-4+b2
> libpython2.7	2.7.2-13
> libquadmath0	4.6.2-12
> libraptor2-0	2.0.6-1+b1
> libsamplerate0	0.1.8-2
> libschroedinger-1.0-0	1.0.11-1
> libsdl1.2debian	1.2.15-1
> libselinux1	2.1.0-4.1
> libsensors4	1:3.3.1-2
> libsexy2	0.1.11-2+b1
> libsgutils2-2	1.33-1
> libslang2	2.2.4-6
> libsmbclient	2:3.6.3-1
> libssh2-1	1.2.8-2
> libstdc++6	4.6.2-12
> libswscale2	4:0.8-1+b1
> libtelepathy-glib0	0.16.2-1
> libtidy-0.99-0	20091223cvs-1.2
> libusbmuxd1	1.0.7-2
> libvpx1	1.0.0-1
> libwbclient0	2:3.6.3-1
> libwebp2	0.1.3-2.1
> libwnck-3-0	3.2.1-1
> libwnck-3-common	3.2.1-1
> libx264-120	2:0.120.2151+gita3f4407-1
> libxcb-dri2-0	1.8-1
> libxcb-render0	1.8-1
> libxcb-shape0	1.8-1
> libxcb-shm0	1.8-1
> libxcb1	1.8-1
> libxml2	2.7.8.dfsg-7
> libyajl2	2.0.4-2
> libzephyr4	3.0.2-2
> linstaller	2.10.7-1
> linstaller-config-semplice	2.10.7-1
> linstaller-frontend-cli	2.10.7-1
> linstaller-modules-base	2.10.7-1
> linux-image-2.6-686	3.2+43
> linux-image-3.2.0-1-686-pae	3.2.4-1
> linux-image-686-pae	3.2+43
> live-config-linstaller	2.10.7-1
> locales	2.13-26
> lsb-base	3.2-28.1
> lsb-release	3.2-28.1
> multiarch-support	2.13-26
> netselect	0.3.ds1-22
> network-manager-gnome	0.9.2.0-2
> notify-osd	0.9.32-1
> perl	5.14.2-7
> perl-base	5.14.2-7
> perl-modules	5.14.2-7
> policykit-1-gnome	0.105-2
> printer-driver-gutenprint	5.2.7-5
> procps	1:3.3.2-3
> psmisc	22.15-2
> python	2.7.2-10
> python-dbus	0.84.0-3
> python-gconf	2.28.1+dfsg-1
> python-gi	3.0.3-3
> python-gnome2	2.28.1+dfsg-1
> python-gobject	3.0.3-3
> python-gst0.10	0.10.22-3
> python-libxml2	2.7.8.dfsg-7
> python-minimal	2.7.2-10
> python-numpy	1:1.5.1-4
> python-xlib	0.14+20091101-1
> python2.7	2.7.2-13
> python2.7-minimal	2.7.2-13
> semplice-apt-conf	0.1
> semplice-archive-keyring	2011.12.25.1
> semplice-artwork	2.10.1
> semplice-artwork-gdm3	2.10.1
> semplice-artwork-theme	2.10.1
> semplice-artwork-wallpapers	2.10.1
> semplice-backup	0.2-1
> semplice-openbox-default-settings	2.10.6
> semplice-utilities	2.10.4-1
> sudo	1.8.3p2-1
> system-base	2.10.6
> system-base-graphical	2.10.6
> system-nonfree	2.10.6
> system-openbox	2.10.6
> sysv-rc	2.88dsf-22
> sysvinit	2.88dsf-22
> sysvinit-utils	2.88dsf-22
> tasksel	3.08
> tasksel-data	3.08
> ttf-droid	20101110+git-3
> usb-modeswitch	1.2.3+repack0-1
> usbmuxd	1.0.7-2
> vim-common	2:7.3.429-1
> vim-tiny	2:7.3.429-1
> whiptail	0.52.14-8
> x11-common	1:7.6+11
> xchat	2.8.8-3.1+b1
> xchat-common	2.8.8-3.1
> xfce4-screenshooter	1.8.0-2
> xkb-data	2.5.1-1
> xserver-xorg	1:7.6+11
> xserver-xorg-input-all	1:7.6+11
> xserver-xorg-video-all	1:7.6+11

Dropped 486 support

The Semplice 32 bit release does not support 486 and 586 machines. An upgrade from 2.0 does NOT force the installation of the new kernel. The old kernel is still supported by Debian, and can be included in custom remasters using pylaivng.

The switch to the 686 kernel brings PAE and SMP support.

Mirrorselect

It is now possible to select the fastest mirror for debian and semplice archives using the program mirrorselect.

The installer can now perform the check during install, too.

Installer changes

The installer got an overhaul on it's modules system, and handles frontends better.

The installer can now reinstall the bootloader without the need to reinstall the system.

semplice-backup

The latest release of the experimental semplice-backup is now installed by default.

Revamped autostart

The autostart scripts have been heavily modified and they're faster and cleaner.

In addition, the user can specify the panel to use and it's configuration. Pcmanfm desktop mode is now supported (use icons=“y” to enable it).

Alan caches

Alan now caches the menus to bring them faster at the user request.

New help menu

A new help menu has been implemented, with links to useful semplice-related resources. The “Semplice on IRC” does not work currently.

XChat

XChat (IRC Client) ships now by default.

Extendable alan configuration

The configuration is now extendable. This means that an user can put only the changes on the user configuration file and not copy the entire system-wide configuration file anymore.

APT tweaks

autoremove is now disabled and triggers are executed only once.

You can install the semplice-apt-conf-nopdiffs package to disable PDiffs (useful if you have a low-end hardware).

Get Semplice Linux 3.0alpha1

See the Download Page

semplice/develop/3.0/relnotes/alpha1.txt · Last modified: 2012/02/08 09:11 by g7