User Tools

Site Tools


semplice:users:advanced:pulseupgrade

Semplice 3.0 upgrade

This wiki page explains how to upgrade to Semplice 3.0 from a Semplice 2.0 “emily” box.

Preparation

Ensure you have the system up-to-date:

sudo apt-get update
sudo apt-get dist-upgrade

Ensure you have the system-openbox package installed:

sudo apt-get install system-openbox

Change the archives

You can use the mirrorselect tool to change the archives:

sudo mirrorselect -s semplice -d pulse

Update the keyrings

You need to update the semplice keyrings to make APT recognize the newly-added archive:

sudo apt-get install semplice-archive-keyring
sudo apt-get update

Upgrade

You can finally begin with the upgrade process.

sudo apt-get dist-upgrade

WARNING: You will be asked to select the default Desktop Manager (DM). Select 'lightdm'.

Removal of obsolete packages

You can use the autoremove function to remove the obsolete emily packages:

sudo apt-get autoremove

Reboot

Reboot now your system to get into the new Semplice 3.0 environment.

Keep in mind that the user settings aren't touched by the upgrade. You can switch to the new theme by using the “Appearance settings” application (On the 'Widget' and “Window Border” tabs, select 'SempliceNight', then apply).

You may want to copy the new Openbox autostart file, you can do so by issuing these commands:

rm ~/.config/openbox/autostart.sh
cp /etc/skel/.config/openbox/autostart ~/.config/openbox
semplice/users/advanced/pulseupgrade.txt · Last modified: 2013/01/02 12:24 by g7